Leoman’s blog

bi blög

Archive for the ‘yedek’ tag

Mikrotik’te uzak noktaya otomatik yedek nasıl alınır?

leave a comment

Bir çok uzak noktada Mikrotik cihaz/PC’ye sahip olduğumuzu düşünelim. Bunları belirli periyotlarla elle yedeklemek unutulma, dosya isimlerinde çıkacak karışıklık vb. türlü türlü problem yüzüden pek mümkün olmayacak, ayrıca bu her noktaya bağlanarak tek tek yedek almak ta ciddi bir zaman kaydı olacaktır.

Bunun yerine otomatik olarak Mikrotik’lere “Şu kadar günde bir yedek al! Aldığın yedekleri bana mail at!” diyebilme seçeneğiniz mevcut.

Bu işlem için öncelikle bir SMTP sunucuya sahip olmalı, Mikrotik cihazlarının bu SMTP server’a erişebilmesi, SMTP server’ın da Mikrotik için kullanıcı doğrulaması gerektirmeden mailleri kabul edebilmesi gerekmektedir.

Tüm bu şartların sağlanmış olduğunu düşünürsek, Mikrotik üzerinden yapılacak iş iki adımdan oluşmakta. Birinci adım olarak kayıtlı bir script yaratma, ikinci adım olarak kayıtlı olan bu script’i belirli zaman aralıklarında çalıştırmak.


/system script add name="Oto-Yedek" \
policy=ftp, read, write, policy, test \
source="/system backup save=oto_yedek \
/tool e-mail send body=\"yedek\" to=\"alici@domain.com\" file=\"oto_yedek\" \
server=\"xxx.xxx.xxx.xxx\" from=\"gonderen@domain.com\" \
subject=\"XXX Mikrotik Yedegi\""

İle yeni Oto-Yedek adından bir yedekleme script’i oluşturduk ve;


/system scheduler add comment="Otomatik yedekleme scriptini zamanlar"\
name="Oto-Yedek-Zamanla" on-event=Oto-Yedek \
start-date="Jun/11/2009" start-time="01:00:00" interval="1d" \
disabled=no

zamanlaması ile hergün saat gece 1’de yedekleme scriptinin çalışmasını sağlayabiliriz. Bu işlem sonucunda artık Mikrotik’e login olmaya gerek kalmadan otomatik olarak yedekler belirttiğiniz e-mail adresine gelecek ve yedek alma zamanını sıfıra indirecektir.

Written by leoman

June 11th, 2009 at 9:51 am

Sil baştan

leave a comment

Sistem, düzen, yapı gibi konularda pimpirikli olmama rağmen kendi işlerime bir o kadar özensizim. Nasıl olduğunu bilmediğim halde kendim için yaptıklarıma haddinden fazla güveniyorum.  Şu zamana kadar bu konuda pek problem yaşamamıştım. Ta ki Kasım başına kadar.

Kasım ayının son haftasında bir blog girdisi yazabilmek için blog’uma girdiğimde bir wordpress açığı sayesinde veritabanının bir güzel indirildiğini fark ettim. Tabii ki muazzam yedekleme sisteminden geri dönebileceğimi bildiğim için huzurlu ve mutluydum.

Sırasıyla veritabanını günlük, haftalık ve aylık yedeklerine geri döndürmeme rağmen sonuç hüsranla sonuçlandı. O kadar uzun bir süreçte Google indexleri değişmiş olması, archive.org’un da 2007 itibariyle index’lememesi de cabası.

Herhangi bir yazılımda açık çıkabilir, bir sisteme izinsiz girilebilir, her biri mümkün olaylar fakat bir o kadarda üzücü bir durum. Belli bir süre kızgın olsam da; kendi sayfam için erişim kayıtlarını normal süresinden daha önce silmek, belli periyotlarda kontrol etmemek eşekliği şahsıma ait bir suç olduğundan artık pek te kızgın değilim artık. Yine de 2004 son çeyreğinden beri yazmış olduğum blog girdilerini kaybetmek üzücü.

Yeni bir başlangıç yapmak yine de güzel. Umarım bu sefer biraz daha düzenli, daha adam akıllı blog yazarım.

Bugün ki blogumuza da burada son verirken “Bakarsan bağ olur, bakmazsan dağ olur” diyerek bitiriyorum. Esen kalın.

Written by leoman

December 14th, 2008 at 11:04 pm

Posted in Genel

Tagged with , ,